Mercurial > MadButterfly
view debian/rules @ 1161:a7faab54e8f8
Fix broken of running animation
- Running animation is stop automatically after a certain time.
- It is 300ms according MBScene._updateUI().
- It is caused by notification of changing DOM tree. The
notification handlers would call MBScene.updateUI() to update
framelines and buttons.
- MBScene.updateUI() would call MBScene.show() after 300ms,
MBScene.show() calls MBScene.parseScene() in turn.
- MBScene.parseScene() would remove duplicate group that is using
by code of running animation, MBScene.doRunNext(). It make
running animation stop.
- fixed by setting MBScene.lockui when a running animation is started
or stoped.
author | Thinker K.F. Li <thinker@codemud.net> |
---|---|
date | Tue, 28 Dec 2010 13:35:34 +0800 |
parents | 12464f1138ae |
children |
line wrap: on
line source
#!/usr/bin/make -f MOZ_EXTENSION_PKG := madbuilder MOZ_XPI_BUILD_COMMAND = make -C inkscape/firefox madbuilder.xpi ; cp inkscape/firefox/madbuilder.xpi . include /usr/share/cdbs/1/rules/debhelper.mk include /usr/share/cdbs/1/class/autotools.mk include /usr/share/mozilla-devscripts/xpi.mk TEMPLATE_PATH=${CURDIR}/debian/madbuilder/usr/local/share/mb install/madbuilder:: install -m 0755 ${CURDIR}/inkscape/firefox/helper_mb.py \ ${CURDIR}/debian/madbuilder/usr/share/madbutterfly/inkscape/usr/bin mkdir -p ${TEMPLATE_PATH} cp -a ${CURDIR}/inkscape/firefox/template ${TEMPLATE_PATH}