view debian/rules @ 1139:a2b068594412

Use pybind with new DOM API (at PYNode). - MBScene.document is a PYDocument instead of PYSPDocument. - MBScene.root is a PYNode isntead of PYSPItem. - getNext() was replaced by next(). - attribute() was replaced by getAttribute(). - getID() was removed, use setAttribute() instead. - MBScene.dom was removed, use MBScene.document.root() instead. - MBScene.nodeToItem was removed, use PYNode.spitem instead.
author Thinker K.F. Li <thinker@codemud.net>
date Wed, 22 Dec 2010 13:27:37 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/usr/bin/make -f

MOZ_EXTENSION_PKG := madbuilder
MOZ_XPI_BUILD_COMMAND = make -C inkscape/firefox madbuilder.xpi ; cp inkscape/firefox/madbuilder.xpi .

include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/autotools.mk
include /usr/share/mozilla-devscripts/xpi.mk

TEMPLATE_PATH=${CURDIR}/debian/madbuilder/usr/local/share/mb

install/madbuilder::
	install -m 0755 ${CURDIR}/inkscape/firefox/helper_mb.py \
		${CURDIR}/debian/madbuilder/usr/share/madbutterfly/inkscape/usr/bin
		
	mkdir -p ${TEMPLATE_PATH}
	cp -a ${CURDIR}/inkscape/firefox/template ${TEMPLATE_PATH}