view debian/madbuilder.postinst @ 1269:97302d2a0a1d

Raise an error for the error. - Never silent fault - If it is fault, it should be fault. - Don't make fault silent. - fix the fault. - the ID should be in the map, but it is not. It is really a fault.
author Thinker K.F. Li <thinker@codemud.net>
date Wed, 12 Jan 2011 20:59:38 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi