view debian/madbuilder.postinst @ 1136:950076863b7e

Fix the tween calculation for the inbetween frames. Now, we can use primitive instead og group to defin ethe animation. Currently, it has been tested against rectangle only. We need to check others as well.
author wycc
date Tue, 21 Dec 2010 14:35:42 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi