Mercurial > MadButterfly
view debian/rules @ 887:8a2d676d9fa3 abs_n_rel_center
Fix bug of clearing COF_TEMP_MARK.
draw_shapes_in_dirty_areas() mark COF_TEMP_MARK on coords and clear
them before leaving. But, it always clear the same one coord for
several times and keep others untouched. It is a logical error. It
can be avoided by avoiding to use the variable at mutliple place for
different purpose in a function, and compiler will check it out by
yelling that the variable is used before assigning a value.
author | Thinker K.F. Li <thinker@codemud.net> |
---|---|
date | Sun, 26 Sep 2010 14:07:05 +0800 |
parents | 12464f1138ae |
children |
line wrap: on
line source
#!/usr/bin/make -f MOZ_EXTENSION_PKG := madbuilder MOZ_XPI_BUILD_COMMAND = make -C inkscape/firefox madbuilder.xpi ; cp inkscape/firefox/madbuilder.xpi . include /usr/share/cdbs/1/rules/debhelper.mk include /usr/share/cdbs/1/class/autotools.mk include /usr/share/mozilla-devscripts/xpi.mk TEMPLATE_PATH=${CURDIR}/debian/madbuilder/usr/local/share/mb install/madbuilder:: install -m 0755 ${CURDIR}/inkscape/firefox/helper_mb.py \ ${CURDIR}/debian/madbuilder/usr/share/madbutterfly/inkscape/usr/bin mkdir -p ${TEMPLATE_PATH} cp -a ${CURDIR}/inkscape/firefox/template ${TEMPLATE_PATH}