view debian/rules @ 1531:5a3597eba722

Switch current layer away before removing a layer. We must switch current layer to another one before removing a layer group node. It avoids a crash since inkscape does not know the group node of the layer is removed, and it would emit a signal on this node later.
author Thinker K.F. Li <thinker@codemud.net>
date Wed, 28 Sep 2011 21:54:39 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/usr/bin/make -f

MOZ_EXTENSION_PKG := madbuilder
MOZ_XPI_BUILD_COMMAND = make -C inkscape/firefox madbuilder.xpi ; cp inkscape/firefox/madbuilder.xpi .

include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/autotools.mk
include /usr/share/mozilla-devscripts/xpi.mk

TEMPLATE_PATH=${CURDIR}/debian/madbuilder/usr/local/share/mb

install/madbuilder::
	install -m 0755 ${CURDIR}/inkscape/firefox/helper_mb.py \
		${CURDIR}/debian/madbuilder/usr/share/madbutterfly/inkscape/usr/bin
		
	mkdir -p ${TEMPLATE_PATH}
	cp -a ${CURDIR}/inkscape/firefox/template ${TEMPLATE_PATH}