Mercurial > MadButterfly
view debian/madbuilder.postinst @ 455:58b6337fb3b2
Fix bugs of pending keys of animated menu.
- When more than one pending key, the animation would be stoped.
- Now, we have a cyclic queue to keep at most 15 pending keys to
make sure pending keys being dispatched without stop current animation
program.
author | Thinker K.F. Li <thinker@branda.to> |
---|---|
date | Thu, 06 Aug 2009 13:15:57 +0800 |
parents | 12464f1138ae |
children |
line wrap: on
line source
#!/bin/bash HEADER="#MadBuilder Configuration#" FOOTER="#End of MadBuilder Configuration#" RC=/etc/mozpluggerrc CONTAIN=`grep "$HEADER" $RC` if [ -z "$CONTAIN" ] then cat <<EOF >> $RC $HEADER application/x-mbsvg:mbsvg: MadButterfly SVG swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file" application/x-h:h: MadButterfly SVG h program swallow(gedit) : gedit "\$file" $FOOTER EOF echo Configuration installed to $RC fi