Mercurial > MadButterfly
view debian/madbuilder.postinst @ 1511:4c349b214877
FSM_window use _compview to decorate domview.
- _compview will dispatch requests for FSM states and transitions to
domview with name of specified component as one of argument list.
- Callers of a compview don't need to know the component that it is
working on.
author | Thinker K.F. Li <thinker@codemud.net> |
---|---|
date | Tue, 10 May 2011 23:15:14 +0800 |
parents | 12464f1138ae |
children |
line wrap: on
line source
#!/bin/bash HEADER="#MadBuilder Configuration#" FOOTER="#End of MadBuilder Configuration#" RC=/etc/mozpluggerrc CONTAIN=`grep "$HEADER" $RC` if [ -z "$CONTAIN" ] then cat <<EOF >> $RC $HEADER application/x-mbsvg:mbsvg: MadButterfly SVG swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file" application/x-h:h: MadButterfly SVG h program swallow(gedit) : gedit "\$file" $FOOTER EOF echo Configuration installed to $RC fi