Mercurial > MadButterfly
view debian/madbuilder.postinst @ 1419:3519f43da037
Check old component before hiding it for a component switching.
Ref: ticket #37 in assembla
- Scribboo try to hide old component before switching to new one.
But, old one was already removed. It cause an error.
- This is fixed by checking old component if it is still existed
before hiding it.
author | Thinker K.F. Li <thinker@codemud.net> |
---|---|
date | Thu, 07 Apr 2011 13:45:07 +0800 |
parents | 12464f1138ae |
children |
line wrap: on
line source
#!/bin/bash HEADER="#MadBuilder Configuration#" FOOTER="#End of MadBuilder Configuration#" RC=/etc/mozpluggerrc CONTAIN=`grep "$HEADER" $RC` if [ -z "$CONTAIN" ] then cat <<EOF >> $RC $HEADER application/x-mbsvg:mbsvg: MadButterfly SVG swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file" application/x-h:h: MadButterfly SVG h program swallow(gedit) : gedit "\$file" $FOOTER EOF echo Configuration installed to $RC fi