Mercurial > MadButterfly
view debian/rules @ 657:32d0eef1ee46
Force type-casting for member variables.
For some member that need a casting for the type is that what we want.
For example, casting a void * type to a struct pointer type. This
force will skip type checking, but it works for the variables with a
generic type and we want to specialize its type.
author | Thinker K.F. Li <thinker@branda.to> |
---|---|
date | Sat, 31 Jul 2010 14:37:19 +0800 |
parents | 12464f1138ae |
children |
line wrap: on
line source
#!/usr/bin/make -f MOZ_EXTENSION_PKG := madbuilder MOZ_XPI_BUILD_COMMAND = make -C inkscape/firefox madbuilder.xpi ; cp inkscape/firefox/madbuilder.xpi . include /usr/share/cdbs/1/rules/debhelper.mk include /usr/share/cdbs/1/class/autotools.mk include /usr/share/mozilla-devscripts/xpi.mk TEMPLATE_PATH=${CURDIR}/debian/madbuilder/usr/local/share/mb install/madbuilder:: install -m 0755 ${CURDIR}/inkscape/firefox/helper_mb.py \ ${CURDIR}/debian/madbuilder/usr/share/madbutterfly/inkscape/usr/bin mkdir -p ${TEMPLATE_PATH} cp -a ${CURDIR}/inkscape/firefox/template ${TEMPLATE_PATH}