view debian/madbuilder.postinst @ 1248:2f9fa5d59e67

Add data_monitor meta-class to monitor accessing on domview_ui. - The monitoring is to prevent from reentry triggered by DOM events. - call 'do*' methods of a monitored class would try to lock domview_ui at first. - The method would not be executed actually if being fault to lock. - You can make monitor to print debug message with environment variable - DATA_MONITOR_DBG=1, or - DATA_MONITOR_DBG=2
author Thinker K.F. Li <thinker@codemud.net>
date Tue, 11 Jan 2011 10:04:14 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi