view debian/rules @ 435:2bdd4f5dd2ca

Make sh_text and sh_stext optional. Since sh_text depends on pango, and we want a version of MadButterfly without Pango (lite version), we make sh_text and sh_stext optional. User can choice which one to enable.
author Thinker K.F. Li <thinker@branda.to>
date Wed, 29 Jul 2009 20:22:36 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/usr/bin/make -f

MOZ_EXTENSION_PKG := madbuilder
MOZ_XPI_BUILD_COMMAND = make -C inkscape/firefox madbuilder.xpi ; cp inkscape/firefox/madbuilder.xpi .

include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/autotools.mk
include /usr/share/mozilla-devscripts/xpi.mk

TEMPLATE_PATH=${CURDIR}/debian/madbuilder/usr/local/share/mb

install/madbuilder::
	install -m 0755 ${CURDIR}/inkscape/firefox/helper_mb.py \
		${CURDIR}/debian/madbuilder/usr/share/madbutterfly/inkscape/usr/bin
		
	mkdir -p ${TEMPLATE_PATH}
	cp -a ${CURDIR}/inkscape/firefox/template ${TEMPLATE_PATH}