view debian/madbuilder.postinst @ 1126:20e15872f3df

Fix bug of passing wrong object to eglQuerySurface(). It supposed to pass EGLSurface to eglQuerySurface(), but a mbe_surface_t was passed.
author Thinker K.F. Li <thinker@codemud.net>
date Mon, 13 Dec 2010 20:19:34 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi