view debian/madbuilder.postinst @ 1339:20cf3e2a0a9d

Fix weir behavior for tweening for opacity. - The opacity is not work for more than one object been tweening. - cause by the buggy style parser. - It is fixed by a better style parser.
author Thinker K.F. Li <thinker@codemud.net>
date Sun, 06 Feb 2011 22:57:33 +0800
parents 12464f1138ae
children
line wrap: on
line source

#!/bin/bash

HEADER="#MadBuilder Configuration#"
FOOTER="#End of MadBuilder Configuration#"
RC=/etc/mozpluggerrc

CONTAIN=`grep "$HEADER" $RC`

if [  -z "$CONTAIN" ]
then
cat <<EOF >> $RC

$HEADER
application/x-mbsvg:mbsvg: MadButterfly SVG
        swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file"
application/x-h:h: MadButterfly SVG h program
	swallow(gedit) : gedit "\$file"
$FOOTER

EOF
echo Configuration installed to $RC
fi