Mercurial > MadButterfly
view debian/madbuilder.postinst @ 1205:1af64bcdfd7d
Move to MBScene._make_layers_integral()
- Old MBScene.parseScene()/create_framelines()/update_framelines() is
too fragile and inefficiently.
- MBScene._make_layers_integral() is more robust that
- separate logic into removing layer group nodes and adding layer
group nodes
- refactory code of create framelines and layers into methods
- it make logic into layers
- framelines and layers are incremental updated to avoid overhead
of creating/destroying all framelines and layer objects.
author | Thinker K.F. Li <thinker@codemud.net> |
---|---|
date | Mon, 03 Jan 2011 22:12:30 +0800 |
parents | 12464f1138ae |
children |
line wrap: on
line source
#!/bin/bash HEADER="#MadBuilder Configuration#" FOOTER="#End of MadBuilder Configuration#" RC=/etc/mozpluggerrc CONTAIN=`grep "$HEADER" $RC` if [ -z "$CONTAIN" ] then cat <<EOF >> $RC $HEADER application/x-mbsvg:mbsvg: MadButterfly SVG swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file" application/x-h:h: MadButterfly SVG h program swallow(gedit) : gedit "\$file" $FOOTER EOF echo Configuration installed to $RC fi