diff src/Makefile.am @ 1129:eca737d33a18

Improve performance of function to compute center of an arc. It is improved by using integer instead of floating point when computing. Some complicate computations are replaced by pre-computed table.
author Thinker K.F. Li <thinker@codemud.net>
date Sat, 18 Dec 2010 15:41:45 +0800
parents fa5f71d4aa04
children 6a71b3c43c67
line wrap: on
line diff
--- a/src/Makefile.am	Sat Dec 18 09:00:55 2010 +0800
+++ b/src/Makefile.am	Sat Dec 18 15:41:45 2010 +0800
@@ -24,7 +24,7 @@
 	observer.c paint.c redraw_man.c rotate.c shape_path.c		\
 	shape_rect.c shift.c subtree_free.c timer.c 			\
 	timertool.c tools.c visibility.c prop.c sprite.c	\
-	mouse.c shape_image.c $(MBAF_SOURCES)
+	mouse.c shape_image.c precomputed.c $(MBAF_SOURCES)
 
 libmbfly_la_CPPFLAGS =
 libmbfly_la_LDFLAGS =
@@ -100,3 +100,7 @@
 testcase_LDFLAGS = -lcunit -L/usr/local/lib/ @pangocairo_LIBS@
 
 EXTRA_PROGRAMS = testcase
+
+precomputed.c precomputed.h: $(top_srcdir)/tools/gen_precomputed_tabs.py
+	$(PYTHON_PATH) $(top_srcdir)/tools/gen_precomputed_tabs.py \
+		precomputed.c precomputed.h