diff examples/dynamic/Makefile.am @ 404:e774868fb7df

merge
author Thinker K.F. Li <thinker@branda.to>
date Tue, 16 Jun 2009 23:03:07 +0800
parents c3fbf599e88f
children 8927814d23b5
line wrap: on
line diff
--- a/examples/dynamic/Makefile.am	Tue Jun 16 23:01:38 2009 +0800
+++ b/examples/dynamic/Makefile.am	Tue Jun 16 23:03:07 2009 +0800
@@ -2,7 +2,8 @@
 
 #SUFFIXES=.svg .mbso
 
-noinst_PROGRAMS = dynamic hello text button.so mytext.so scene.so
+noinst_PROGRAMS = dynamic hello text
+noinst_LTLIBRARIES = button.la mytext.la scene.la
 EXTRA_DIST = menu.svg button.svg
 
 dynamic_SOURCES = main.c
@@ -25,12 +26,20 @@
 text_LDFLAGS = @pangocairo_LIBS@ 
 text_LDADD = $(top_builddir)/src/libmbfly.la
 
-button.so: button.o
-	$(CC) $(CFLAGS) -I ../../include -shared -o $@ $<
+
+button_la_SOURCES = button.c
+button_la_LDFLAGS = -module -avoid-version -rpath /nowhere -shared
+
 
-button.o: button.c button.h
+mytext_la_SOURCES = mytext.c
+mytext_la_LDFLAGS = -module -avoid-version -rpath /nowhere -shared
+
 
-button.c: button.mb
+scene_la_SOURCES = scene.c
+scene_la_LDFLAGS = -module -avoid-version -rpath /nowhere -shared
+
+
+button.c: button.mb button.h
 	m4 -I $(top_srcdir)/tools mb_c_source.m4 $< > $@
 
 button.h: button.mb
@@ -39,12 +48,7 @@
 button.mb: button.svg
 	$(top_srcdir)/tools/svg2code.py $< $@
 
-mytext.so: mytext.o
-	$(CC) $(CFLAGS) -I ../../include -shared -o $@ $<
-
-mytext.o: mytext.c mytext.h
-
-mytext.c: mytext.mb
+mytext.c: mytext.mb mytext.h
 	m4 -I $(top_srcdir)/tools mb_c_source.m4 $< > $@
 
 mytext.h: mytext.mb
@@ -53,12 +57,7 @@
 mytext.mb: mytext.svg
 	$(top_srcdir)/tools/svg2code.py $< $@
 
-scene.so: scene.o
-	$(CC) $(CFLAGS) -I ../../include -shared -o $@ $<
-
-scene.o: scene.c scene.h
-
-scene.c: scene.mb
+scene.c: scene.mb scene.h
 	m4 -I $(top_srcdir)/tools mb_c_source.m4 $< > $@
 
 scene.h: scene.mb