diff src/Makefile.am @ 465:d8181696b689 Android_Skia

Move functions into graphic engine layers. Cairo and Skia have their own header files and C/C++ files. Some functions are refactoried and move into graphic engine layer to make reset of MadButterfly independently from graphic engines.
author Thinker K.F. Li <thinker@branda.to>
date Thu, 12 Nov 2009 21:22:30 +0800
parents 271212f325b4
children cd6f57b9b104
line wrap: on
line diff
--- a/src/Makefile.am	Thu Nov 12 21:16:13 2009 +0800
+++ b/src/Makefile.am	Thu Nov 12 21:22:30 2009 +0800
@@ -31,8 +31,12 @@
 libmbfly_la_SOURCES += X_supp.c
 endif
 
+if CAIRO_BACKEND
+libmbfly_la_SOURCES += graph_engine_cairo.c
+
 libmbfly_la_CPPFLAGS = @cairo_CFLAGS@ @pangocairo_CFLAGS@
 libmbfly_la_LDFLAGS = @cairo_LIBS@ @pangocairo_LIBS@
+endif
 
 X_main_SOURCES = X_main.c
 X_main_LDADD = $(top_builddir)/src/libmbfly.la