diff examples/dynamic/Makefile.am @ 242:d3fe0a0f3a8b

Implement MBApp API and modify the dynamic example to use this API.
author wycc
date Wed, 31 Dec 2008 22:37:21 +0800
parents 2637519e2bd7
children 4df1b766bbf5
line wrap: on
line diff
--- a/examples/dynamic/Makefile.am	Wed Dec 31 02:08:40 2008 +0800
+++ b/examples/dynamic/Makefile.am	Wed Dec 31 22:37:21 2008 +0800
@@ -20,7 +20,7 @@
 menu.c: menu.mb
 	m4 -I $(top_srcdir)/tools mb_c_source.m4 $< > $@
 
-button.so: button.o
+button.so: button.o button.h
 	gcc -shared -o button.so button.o
 
 button.mb: $(srcdir)/button.svg
@@ -31,3 +31,15 @@
 
 button.c: button.mb
 	m4 -I $(top_srcdir)/tools mb_c_source.m4 $< > $@
+
+scene.so: scene.o scene.h
+	gcc -shared -o scene.so scene.o
+
+scene.mb: $(srcdir)/scene.svg
+	$(top_srcdir)/tools/svg2code.py $? $@
+
+scene.h: scene.mb
+	m4 -I $(top_srcdir)/tools mb_c_header.m4 $< > $@
+
+scene.c: scene.mb
+	m4 -I $(top_srcdir)/tools mb_c_source.m4 $< > $@