diff inkscape/Makefile.am @ 256:cac9ad3df633

* use Autotool to install inkscape ext. of MadButterfly ( experimental! ) * pass distcheck
author "Mat <MatLinuxer2@gmail.com>"
date Thu, 15 Jan 2009 02:15:35 +0800
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/inkscape/Makefile.am	Thu Jan 15 02:15:35 2009 +0800
@@ -0,0 +1,8 @@
+extdir=$(datadir)/inkscape/extenstions
+ext_py=AssignSymbol.py MB_EditButton.py MB_Frame.py
+ext_DATA=$(ext_py) MB_EditButton.inx MB_Frame.inx MB_assignSymbol.inx mbtest.svg
+
+install-data-hook:
+	for file in $(ext_py); do cd "$(DESTDIR)$(extdir)"; tgt=$${file#inkscape/}; chmod +x $${tgt}; done
+
+EXTRA_DIST=$(ext_DATA)