diff configure.ac @ 543:7630dac0a104 Android_Skia

Create Makefile for nodejs plugin
author Thinker K.F. Li <thinker@branda.to>
date Fri, 04 Jun 2010 22:29:08 +0800
parents 7cb0b59e2c3f
children 16f4f8305c8f
line wrap: on
line diff
--- a/configure.ac	Wed May 26 00:51:12 2010 +0800
+++ b/configure.ac	Fri Jun 04 22:29:08 2010 +0800
@@ -86,6 +86,18 @@
 cairo=true
 [fi]
 
+AC_ARG_ENABLE([nodejs],
+	[  --enable-nodejs	Turn on nodejs support],
+[case "${enableval}" in
+  yes) nodejs=true ;;
+  no) nodejs=false ;;
+  *) AC_MSG_ERROR([bad value ${enableval} for --enable-nodejs]) ;;
+esac],[nodejs=false])
+[if [ x"${nodejs}" = xtrue ]; then ]
+  AC_CHECK_PROG([has_node], [node], [true], [false])
+[fi]
+AM_CONDITIONAL([NODEJS], [test x"${nodejs}-${has_node}" = xtrue-true])
+
 # Define AM and AC variable for sh_text
 AM_CONDITIONAL([SH_TEXT], [test x$sh_text = xtrue -a x$cairo = xtrue])
 [if [ x"${sh_text}" = xtrue -a x$cairo = xtrue ]; then]
@@ -118,6 +130,7 @@
                  src/Makefile
                  include/Makefile
                  inkscape/Makefile
+		 nodejs/Makefile
                  tools/Makefile])
 
 AH_TEMPLATE([SH_TEXT],[Enable sh_text object])