diff configure.ac @ 1519:74635b07a83a

Porting Skia backend to latest version and with X
author Thinker K.F. Li <thinker@codemud.net>
date Tue, 17 May 2011 12:17:15 +0800
parents 41190d180b97
children
line wrap: on
line diff
--- a/configure.ac	Sat May 14 12:20:57 2011 +0800
+++ b/configure.ac	Tue May 17 12:17:15 2011 +0800
@@ -134,6 +134,7 @@
     X-cairo-*|X-openvg-imlib2|X-openvg-dummy) ;;
     dfb-cairo-*) ;;
     console-openvg-imlib2|console-openvg-dummy) ;;
+    X-skia-imlib2) ;;
     none-*-*) ;;
     *)] AC_MSG_ERROR([The combination of --with-backend=${backend}, --with-graphic-engine=${graphic_engine} and --with-image-loader=${image_loader} is invalid]) [;;
 esac]
@@ -226,9 +227,9 @@
 [fi]
 
 AM_CONDITIONAL([XSHM],
-	[test x"${xshm}" = xtrue -a x"${graphic_engine}" = x"cairo" -a x$backend = x'X'])
+	[test x"${xshm}" = xtrue -a \( x"${graphic_engine}" = x"cairo" -o x"${graphic_engine}" = x"skia" \) -a x$backend = x'X'])
 
-[if [ x"${xshm}" = xtrue -a x"${graphic_engine}" = x"cairo" -a x$backend = x'X' ]; then]
+[if [ x"${xshm}" = xtrue -a \( x"${graphic_engine}" = x"cairo" -o x"${graphic_engine}" = x"skia" \) -a x$backend = x'X' ]; then]
     AC_DEFINE([XSHM])
 [fi]