diff src/Makefile.am @ 175:67e13d694230

Fix bug of src/Makefile.am & examples accept PREFIX variable. - src/Makefile.am install header files into $(prefix)/include/mb instead of $(prefix)/include original. - examples find headers, M4 macro files, and tools with PREFIX varaible. - default value of PREFIX is /usr/local. - user can change PREFIX with paramter of make command, for example 'make PREFIX=../../build/dest', if MadButterfly was installed there. - Users can install MadButterfly in their specified directory, for example, './configure --prefix=${PWD}/dest', the binary will installed in dest/.
author Thinker K.F. Li <thinker@branda.to>
date Fri, 31 Oct 2008 15:15:44 +0800
parents 7ca25f18902f
children d0646a6df46f
line wrap: on
line diff
--- a/src/Makefile.am	Fri Oct 31 10:57:47 2008 +0800
+++ b/src/Makefile.am	Fri Oct 31 15:15:44 2008 +0800
@@ -1,3 +1,4 @@
+includedir = $(prefix)/include/mb
 include_HEADERS = animate.h mb.h mb_timer.h mb_types.h observer.h paint.h redraw_man.h shapes.h tools.h X_supp.h
 
 lib_LTLIBRARIES = libmbfly.la