diff src/Makefile.am @ 194:45d9a1e2764d

Add mb_subtree_free animate action and fix bugs. - Free members of a coord in rdman_coord_subtree_free(). - Fix core dump issue of subject_notify() that can not free subjects well.
author Thinker K.F. Li <thinker@branda.to>
date Wed, 19 Nov 2008 20:53:40 +0800
parents c7e5b8779bb5
children 29e1b2bffe4c
line wrap: on
line diff
--- a/src/Makefile.am	Wed Nov 19 11:26:01 2008 +0800
+++ b/src/Makefile.am	Wed Nov 19 20:53:40 2008 +0800
@@ -4,7 +4,10 @@
 
 noinst_PROGRAMS = X_main
 
-libmbfly_la_SOURCES = animate.c chgcolor.c coord.c event.c geo.c observer.c paint.c redraw_man.c rotate.c shape_path.c shape_rect.c shape_text.c shift.c timer.c timertool.c tools.c visibility.c X_supp.c
+libmbfly_la_SOURCES = animate.c chgcolor.c coord.c event.c geo.c	\
+	observer.c paint.c redraw_man.c rotate.c shape_path.c		\
+	shape_rect.c shape_text.c shift.c subtree_free.c timer.c 	\
+	timertool.c tools.c visibility.c X_supp.c
 libmbfly_la_CPPFLAGS = @cairo_CFLAGS@
 libmbfly_la_LDFLAGS = @cairo_LIBS@