diff src/Makefile.am @ 464:271212f325b4 Android_Skia

Conditional compile with Cairo and Skia. Some components are also affected. For example, sh_text, sh_stext, X_supp...etc. All affected ones are conditional compiled.
author Thinker K.F. Li <thinker@branda.to>
date Thu, 12 Nov 2009 21:16:13 +0800
parents 2bdd4f5dd2ca
children d8181696b689
line wrap: on
line diff
--- a/src/Makefile.am	Sun Nov 08 00:37:29 2009 +0800
+++ b/src/Makefile.am	Thu Nov 12 21:16:13 2009 +0800
@@ -16,7 +16,7 @@
 libmbfly_la_SOURCES= animate.c chgcolor.c coord.c event.c geo.c	\
 	observer.c paint.c redraw_man.c rotate.c shape_path.c		\
 	shape_rect.c shift.c subtree_free.c timer.c 			\
-	timertool.c tools.c visibility.c X_supp.c prop.c sprite.c	\
+	timertool.c tools.c visibility.c prop.c sprite.c	\
 	mouse.c shape_image.c img_ldr.c $(MBAF_SOURCES)
 
 if SH_TEXT
@@ -27,6 +27,10 @@
 libmbfly_la_SOURCES += shape_stext.c
 endif
 
+if X_SUPP
+libmbfly_la_SOURCES += X_supp.c
+endif
+
 libmbfly_la_CPPFLAGS = @cairo_CFLAGS@ @pangocairo_CFLAGS@
 libmbfly_la_LDFLAGS = @cairo_LIBS@ @pangocairo_LIBS@