diff src/Makefile.am @ 1105:1b3e295f3acb

Add a dummy image loader. It is used with --with-image-loader=dummy of configure. It is a dummy image load that always abort the program when the program try to load or free an image. This module can be used for early stage of a new platform backend.
author Thinker K.F. Li <thinker@codemud.net>
date Sun, 05 Dec 2010 21:04:12 +0800
parents a7f16c967a0b
children fa5f71d4aa04
line wrap: on
line diff
--- a/src/Makefile.am	Sun Dec 05 14:27:17 2010 +0800
+++ b/src/Makefile.am	Sun Dec 05 21:04:12 2010 +0800
@@ -56,6 +56,10 @@
 libmbfly_la_LDFLAGS += @imlib2_LIBS@
 endif
 
+if DUMMY_IMG_LOADER
+libmbfly_la_SOURCES += img_ldr_dummy.c
+endif
+
 if CAIRO_GRAPH_ENGINE
 libmbfly_la_SOURCES += graph_engine_cairo.c