diff configure.ac @ 1105:1b3e295f3acb

Add a dummy image loader. It is used with --with-image-loader=dummy of configure. It is a dummy image load that always abort the program when the program try to load or free an image. This module can be used for early stage of a new platform backend.
author Thinker K.F. Li <thinker@codemud.net>
date Sun, 05 Dec 2010 21:04:12 +0800
parents 8d70dbb70d38
children fa5f71d4aa04
line wrap: on
line diff
--- a/configure.ac	Sun Dec 05 14:27:17 2010 +0800
+++ b/configure.ac	Sun Dec 05 21:04:12 2010 +0800
@@ -105,7 +105,7 @@
 	[case "${withval}" in
 	    ('cairo') image_loader="cairo" ;;
 	    ('imlib2') image_loader="imlib2" ;;
-	    ('no') image_loader="none" ;;
+	    ('dummy') image_loader="dummy" ;;
 	    (*) AC_MSG_ERROR([bad value ${withval} for --with-image-loader])
 	    	;;
 	esac], [image_loader="cairo"])
@@ -123,7 +123,7 @@
 
 # Validate options
 [case "${backend}-${graphic_engine}-${image_loader}" in
-    X-cairo-*|X-openvg-imlib2) ;;
+    X-cairo-*|X-openvg-imlib2|X-openvg-dummy) ;;
     dfb-cairo-*) ;;
     none-*-*) ;;
     *)] AC_MSG_ERROR([The combination of --with-backend=${backend}, --with-graphic-engine=${graphic_engine} and --with-image-loader=${image_loader} is invalid]) [;;
@@ -202,6 +202,13 @@
     AC_DEFINE([IMLIB2_IMG_LOADER])
 [fi]
 
+AM_CONDITIONAL([DUMMY_IMG_LOADER],
+	[test x"${image_loader}" = x"dummy"])
+
+[if [ x"${image_loader}" = x"dummy" ]; then]
+    AC_DEFINE([DUMMY_IMG_LOADER])
+[fi]
+
 AM_CONDITIONAL([XSHM],
 	[test x"${xshm}" = xtrue -a x"${graphic_engine}" = x"cairo" -a x$backend = x'X'])
 
@@ -252,6 +259,7 @@
 AH_TEMPLATE([DFB_GRAPH_ENGINE], [Enable DirectFB Graphic Engine])
 AH_TEMPLATE([CAIRO_IMG_LOADER], [Enable Cairo Image Loader])
 AH_TEMPLATE([IMLIB2_IMG_LOADER], [Enable Imlib2 Image Loader])
+AH_TEMPLATE([DUMMY_IMG_LOADER], [Enable Dummy Image Loader])
 AH_TEMPLATE([X_BACKEND], [Enable X backend])
 AH_TEMPLATE([DFB_BACKEND], [Enable DirectFB backend])
 AH_TEMPLATE([XSHM], [Enable XSHM])