Mercurial > MadButterfly
comparison debian/madbuilder.postinst @ 386:12464f1138ae
[MadBuilder] Install template and configuration to mozpluggerrc
author | Ben Lau <xbenlau@gmail.com> |
---|---|
date | Fri, 10 Apr 2009 03:14:49 +0800 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
385:28e822aa84e5 | 386:12464f1138ae |
---|---|
1 #!/bin/bash | |
2 | |
3 HEADER="#MadBuilder Configuration#" | |
4 FOOTER="#End of MadBuilder Configuration#" | |
5 RC=/etc/mozpluggerrc | |
6 | |
7 CONTAIN=`grep "$HEADER" $RC` | |
8 | |
9 if [ -z "$CONTAIN" ] | |
10 then | |
11 cat <<EOF >> $RC | |
12 | |
13 $HEADER | |
14 application/x-mbsvg:mbsvg: MadButterfly SVG | |
15 swallow(Inkscape) : /usr/share/madbutterfly/inkscape/usr/bin/helper_mb.py "\$file" | |
16 application/x-h:h: MadButterfly SVG h program | |
17 swallow(gedit) : gedit "\$file" | |
18 $FOOTER | |
19 | |
20 EOF | |
21 echo Configuration installed to $RC | |
22 fi |